Migration Solutions for ColdFusion Applications to ASP.NET
      
New Atlanta Product Forums Profile | Search | Login | RSS
New Topic Reply   Previous Page  Page: 1   Next Page

Thread: JSF application very slow on SE 6.0. (Any patches ?)
Created on: 01/19/09 01:00 AM Replies: 2
pankajsingla


Joined: 09/23/08
Posts: 7
JSF application very slow on SE 6.0. (Any patches ?)
01/19/09 1:00 AM

Hi,

We are using JSF with SE 6.0. Earlier we had been using Icefaces but took it out when it we faces "user session expired" problem (a solution has been posed in these forums since then).

But we are having performance issues with SE 6.0. While the application is working fine with Tomcat, the response time on SE 6.0 is slow. Our other applications which don't use JSF work fine on SE 6.0.

Are there any specific settings for JSF or patches we need to apply to make it faster ?

Thanks,

Pankaj
Link | Top | Bottom
mattm


Joined: 10/10/07
Posts: 266
RE: JSF application very slow on SE 6.0. (Any patches ?)
01/19/09 10:28 AM

Try using SE's Jar Indexing feature in your webapp.
Here is how to do it:

-----
To use this feature:
a. Utilize the -i option of the jar tool to generate a Jar Index
for as many JARs (in WEB-INF/lib) as you wish
(multiple INDEX.LIST files can be used).
b. Pass an init parameter named
com.newatlanta.servletexec.useJarIndex
to your webapp with a value of true.
A JVM System Property by the same name could also be used
to enable this globally for all webapps.
c. See http://java.sun.com/j2se/1.5.0/docs/guide/jar/jar.html
for more information about the JAR Index mechanism.
-----

I don't know for certain if this will help or not.
Trying it is the best way to find out.
When you index the JARs in your webapp, I recommend that you index all of them.
I believe this can be done in one invocation of the jar tool by using an asterisk (*).

If that does not help, then please send a simplified version of your webapp which demonstrates this issue to support@servletexec.com.

I'd be happy to dig further.

Matt
Matt McGinty, New Atlanta Technical Support
Link | Top | Bottom
mattm


Joined: 10/10/07
Posts: 266
RE: JSF application very slow on SE 6.0. (Any patches ?)
10/12/09 4:24 PM

The solution to the "user session expired" problem (hinted in this threads opening post) is here:

http://forums.newatlanta.com/messages.cfm?threadid=8F32893B-0F63-4A2B-8C59F082503C2D8A

Matt
Matt McGinty, New Atlanta Technical Support
Link | Top | Bottom

New Post
Please login to post a response.


company media information terms of use privacy policy contact us
This page was dynamically built on the BlueDragon CFML Engine